<! >

Особенности 1С Предприятие 8, которые мало кто знает. Группировка в отчете (как в Excel)

Часто бывает так, что в отчетах большое количество группировок («плюсики») Для управления группировками можно кликнуть мышкой на пустое пространство, в котором расположено управление группировками («плюсики») и установить требуемый уровень группировок. Но для более легкого управления можно включить отображение колонок (меню «Таблица» – «Вид» – «Отображать заголовки») в таблице и выбор уровня группировок будет аналогичен выбору уровня группировок в Excel Ключевые фразы: Будни1СОсобенности 1С Предприятие 8

11:34:02 7.12.2017

Особенности 1С Предприятие 8, которые мало кто знает. Настройка списков пользователем – добавление колонок, которые не предусмотрел разработчик.

Часто в списках документов, справочников и др. не хватает колонок для просмотра и отбора информации. В настройках формы можно управлять только теми колонками, которые предпочли сделать доступными разработчики (меню «Все действия» - «Изменить форму»). Достаточно выбрать ссылочное поле на элемент справочника или документ (в примере на рисунке - это поле «Автор» – ссылка на справочник «Пользователи») и нажать кнопку «Добавить поля» (эта кнопка станет доступной) и мы можем добавить в список реквизиты этого объекта: И не всегда консультанты из компаний франчайзи 1С вам расскажут об этом. Кстати, для списков, которые содержат различные виды документов это тоже работает. Ключевые фразы: Будни1СОсобенности 1С Предприятие 8

11:13:33 5.12.2017

Особенности 1С Предприятие 8, которые мало кто знает. Быстрый ввод даты.

Если мы вводим дату текущего года, то год в поле вводить не обязательно – достаточно ввести только день и месяц. После нажатия Enter текущий год установится автоматически. Аналогично и с текущим месяцем – достаточно только ввести день и нажать Enter, а месяц и год установятся автоматом. Ключевые фразы: Будни1С 8Особенности 1С Предприятие 8

10:53:06 5.12.2017

Пятница 10.11.2017 (Юмор)

Нецензурные этикетки Пятничная подборка (юмор) Ключевые фразы: юмор

10:34:04 10.11.2017

1С: Предприятие 8. Условное оформление – сравнение с текущей датой при каждом обновлении динамического списка

В данной публикации рассмотрим пример раскрашивания строк просроченных документов в журнале документов (динамическом списке) от текущей даты и текущего времени. Наша задача – раскрасить розовым цветом строку, если Контрольный срок меньше Текущей даты с учетом того, что текущая дата постоянно меняется. То есть текущую дату надо считывать динамически, а не определять при первом открытии. Мы узнаем, как в управляемой форме: - использовать обработчик ожидания; - программно настроить условное оформление динамического списка Допустим, у нас есть документ «Умный заказ» с реквизитом «КонтрольныйСрок» и типом «Дата» (состав даты «Дата и время»):   И журнал документов «УмныйЗаказ» с графой «КонтрольныйСрок», соответствующей этому реквизиту:   Наша задача – раскрасить розовым цветом строку, если Контрольный срок меньше Текущей даты с учетом того, что текущая дата постоянно изменяется. Создадим управляемую форму:   Теперь при создании на сервере мы вызовем процедуру раскрашивания строк «ОбновленияОтображенияПросрочкиНаСервере».  И будем вызывать эту процедуру с заданной периодичностью. То есть, при создании на сервере: */ &НаСервере Процедура ПриСозданииНаСервере(Отказ, Стандартнаяобработка) ОбновленияОтображенияПросрочкиНаСервере(); КонецПроцедуры При открытии подключим обработчик ожидания: */ &НаКлиенте Процедура ПриОткрытии(Отказ) ПериодАвтообновления = 30;//Здесь указываем период автообновления динамического списка ЭтотОбъект.Элементы.Список.ПериодАвтоОбновления = ПериодАвтообновления; ПодключитьОбработчикОжидания("ОбновленияОтображенияПросрочки", ПериодАвтообновления,Ложь); КонецПроцедуры &НаКлиенте Процедура ОбновленияОтображенияПросрочки() Экспорт ОбновленияОтображенияПросрочкиНаСервере(); КонецПроцедуры Таким образом, с периодичностью, указанной в переменной ПериодАвтообновления мы будем вызывать процедуру раскрашивания строк: */ &НаСервере Процедура ОбновленияОтображенияПросрочкиНаСервере() //Красим если просрочен срок УО = ЭтотОбъект.Список.КомпоновщикНастроек.ФиксированныеНастройки.УсловноеОформление.Элементы; //если условное оформление уже задано, то удалим его и создадим заново Для каждого Стр Из УО Цикл Если Стр.Представление="Отбор_просрочки" Тогда УО.Удалить(Стр); Прервать; КонецЕсли; КонецЦикла; //создание условного оформления ЭлементУО = УО.Добавить(); ЭлементУО.Представление="Отбор_просрочки"; ЭлементУО.Использование = Истина; ЭлементУО.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Розовый); ЭлементУсловия = ЭлементУО.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных")); ЭлементУсловия.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("КонтрольныйСрок"); ЭлементУсловия.ВидСравнения = ВидСравненияКомпоновкиДанных.Меньше; ЭлементУсловия.ПравоеЗначение = ТекущаяДата(); КонецПроцедуры В этой процедуре мы программно создали условное оформление нашего динамического списка. Результат:     Ключевые фразы: 1С 8

10:25:41 14.03.2017

Новый релиз бесплатного, обновляемого сборника игр под Android "Luchik games" (0.1.04)

Дополнение к публикации Бесплатный, обновляемый сборник игр для устройств с ОС Android. Скачать. В игре ZILLO появился новый уровень "Опытный" Добавлена возможность регистрации и просмотра своих рекордов в играх. Желаю Вам приятно провести время с этим сборником игр! Установить можно с Google Play: Ключевые фразы: Будни1С 8

14:41:13 8.12.2016

Бесплатный, обновляемый сборник игр для устройств с ОС Android. Скачать.

Zillo - это логическая игра-головоломка против Искусственного Интеллекта (ИИ). Всё происходит на поле 8х8 клеток с положительными и отрицательными цифрами.Во время первого хода игрок выбирает цифру из горизонтального ряда, затем ИИ из вертикального, пересекающего ряд игрока в этой точке. Потом игрок выбирает цифру из горизонтального ряда, пересекающего точку, выбранную ИИ. И так до тех пор, пока поле не очистится или не будут исчерпаны все варианты ходов.     Попробуйте .Игра кажется простой, но даже на первом уровне не все однозначно Установить можно с Google Play: Вот еще несколько снимков экрана: В следующем релизе планирую: Добавить запись рекордов Добавить новый уровень в игру ZILLO А еще новую игру и/или головоломку. Какую пожелаете - пишите в комментариях!!! Ключевые фразы: мобильное приложение

15:58:07 2.12.2016

Новый проект Павла Дурова Telegraph

Новый проект Павла Дурова Telegraph - минималистичный гибрид мессенджера и платишера, а именно — анонимный имиджборд. Есть только три поля: «заголовок», «автор», «текст публикации», то есть только то, что нужно для создания стандартной публикации, обзора или статьи. Вот пример: Мой киборг-сеть программных разработок Единственным минусом можно обозначить то, что если вы не храните cookie или линки на страницы, то после закрытия окна Telegraph ваш пост канет в лету. Найдет ли свою аудиторию Telegra.ph покажет время. Ключевые фразы: TelegraphБудни

13:16:44 24.11.2016

Задвоились предопределенные элементы справочников? Выход есть!

*/ Задвоились предопределенные элементы справочников? Выход есть! Это может произойти как по причине того, что при обмене данными в режиме загрузки уникальность предопределенного элемента в пределах области информационной базы не проверяется, так и при объединении/обновлении конфигураций. При попытке переименовать, или, например, пометить на удаление 1С показывает сообщение «Предопределенный элемент не уникален». В этой статье мы напишем обработку, которая позволит избавиться от дублей предопределенных элементов справочника. Алгоритм следующий: Первым делом мы найдем задвоенные (затроенные и т.д.) предопределенные элементы всех справочников. Затем определим на какие элементы больше всего ссылаются другие объекты базы. С учетом количества ссылок, определим как «правильные» те, на которые меньше всего других ссылок. Оставим эти элементы предопределенными, а дубликаты сделаем непредопределенными (наименование сделаем как у предопределенных, для возможности дальнейшей замены всех ссылок на «правильный» соответствующий предопределенный элемент справочника). Дальше можно заменить все ссылки объектов к этим дубликатам ссылками на те элементы, которые мы решили оставить предопределенными и при необходимости удалить дубликаты. Мы просто предложим пометить дубликаты на удаление. Создадим новую обработку, и добавим табличную часть «ЗадублированныеСправочники»:   Реквизиты табличной части «ИмяСправочника», «СинонимСправочника» и «ИмяПредопределенныхДанных» - переменная строка неограниченной длины; «КоличествоДублей» и «КоличествоСсылок» - неотрицательное число; «ОставитьПредопределенным» - булево; «ЭлементСправочника» тип «Справочник». Создадим основную форму и разместим на ней табличную часть и кнопки «1. Заполнить», «2. Подсказать правильные», «3. Оставить предопределенными только отмеченные»:   В теле процедуры обработчика нажатия кнопки «1. Заполнить» будем вызывать процедуру ЗадублированныеСправочникиЗаполнить() Процедура ЗадублированныеСправочникиЗаполнить() //Очистим табличную часть, так как после выполнения конечного этапа //проконтролируем, что дубликаты исчезли ЗадублированныеСправочники.Очистить(); //Построим текст запроса, для определения дубликатов //предопределенных элементов справочника #ИмяСправочника ТекстЗапроса = "ВЫБРАТЬ | #ИмяСправочника.Ссылка КАК Ссылка, | #ИмяСправочника.ИмяПредопределенныхДанных КАК ИмяПредопределенныхДанных |ПОМЕСТИТЬ ВремТЗ |ИЗ | Справочник.#ИмяСправочника КАК #ИмяСправочника |ГДЕ | #ИмяСправочника.Предопределенный |; | |//////////////////////////////////////////////////////////////////////////////// |ВЫБРАТЬ | ВремТЗ.ИмяПредопределенныхДанных, | КОЛИЧЕСТВО(РАЗЛИЧНЫЕ ВремТЗ.Ссылка) КАК КоличествоДублей |ПОМЕСТИТЬ Дубли |ИЗ | ВремТЗ КАК ВремТЗ | |СГРУППИРОВАТЬ ПО | ВремТЗ.ИмяПредопределенныхДанных |; | |//////////////////////////////////////////////////////////////////////////////// |ВЫБРАТЬ | Дубли.ИмяПредопределенныхДанных КАК ИмяПредопределенныхДанных, | Дубли.КоличествоДублей КАК КоличествоДублей, | ""#ИмяСправочника"" КАК ИмяСправочника, | ""#СинонимСправочника"" КАК СинонимСправочника, | ЛОЖЬ КАК ОставитьПредопределенным, | ВремТЗ.Ссылка КАК ЭлементСправочника |ИЗ | Дубли КАК Дубли | ЛЕВОЕ СОЕДИНЕНИЕ ВремТЗ КАК ВремТЗ | ПО Дубли.ИмяПредопределенныхДанных = ВремТЗ.ИмяПредопределенныхДанных |ГДЕ | Дубли.КоличествоДублей > 1"; Запрос = Новый Запрос; //Предупреждая замечания читателей и вопреки всем рекомендациям, будем выполнять запрос в цикле //для каждого справочника - //это читабельней и не приводит к существенной нагрузке на информационную базу, //нежели одним запросом охватывать все справочники //(что, при определенных ограничениях на количество объединений может и вовсе не представлятся возможным) Для Каждого Стр Из Метаданные.Справочники Цикл ИмяСправочника = Стр.Имя; СинонимСправочника = Стр.Синоним; ПоказатьОповещениеПользователя("Поиск по справочнику " + СинонимСправочника); Запрос.Текст = ТекстЗапроса; Запрос.Текст = СтрЗаменить(Запрос.Текст, "#ИмяСправочника", ИмяСправочника); Запрос.Текст = СтрЗаменить(Запрос.Текст, "#СинонимСправочника", СинонимСправочника); Результат = Запрос.Выполнить(); //В этом цикле добавляем строки в табличную часть Если Не Результат.Пустой() Тогда Выборка = Результат.Выбрать(); Пока Выборка.Следующий() Цикл НовСтр = ЗадублированныеСправочники.Добавить(); ЗаполнитьЗначенияСвойств(НовСтр, Выборка); КонецЦикла; КонецЕсли; КонецЦикла; //Отстортируем табличную часть и скроем колонку, в которой отображается //количество ссылок на предопределенный элемент справочника //(по количеству ссылок на объект, пользователю будет легче определить "правильный" объект) ЗадублированныеСправочники.Сортировать("ИмяСправочника, ИмяПредопределенныхДанных"); ЭлементыФормы.ЗадублированныеСправочники.Колонки.КоличествоСсылок.Видимость = Ложь; КонецПроцедуры В процессе работы данной процедуры мы будем следить за тем, какие справочники проверяются на дубли в специальном окне:   Это окно реализовано функцией глобального контекста ПоказатьОповещениеПользователя() При окончании процедуры мы получим заполненную дубликатами табличную часть, в колонке «Правильные» указывается предопределенный элемент справочника, который необходимо оставить:   Теперь пользователь может либо сам определить «правильные» предопределенные, либо воспользоваться подсказкой по кнопке «2. Подсказать правильные». В теле процедуры обработчика нажатия этой кнопки будем вызывать процедуру ПодсказатьПравильные() – как уже было сказано, подсказка заключается в определении количества ссылающихся объектов информационной базы на предопределенный элемент справочника – чем больше ссылок на элемент, тем он «правильнее» (меньше ссылок придется заменять в дальнейшем): Процедура ПодсказатьПравильные() //Находим ссылки на дубликаты ТаблицаСсылок = НайтиПоСсылкам(ЗадублированныеСправочники.ВыгрузитьКолонку("ЭлементСправочника")); ТаблицаСсылок.Колонки.Добавить("Количество", Новый ОписаниеТипов("Число")); ТаблицаСсылок.ЗаполнитьЗначения(1,"Количество"); //считаем количество ссылок на каждый дубликат ТаблицаСсылок.Свернуть("Ссылка", "Количество"); //Заполняем колонку "Количество ссылок" Для Каждого СтрТаблицаСсылок Из ТаблицаСсылок Цикл НайденныеСтроки = ЗадублированныеСправочники.НайтиСтроки(Новый Структура("ЭлементСправочника, КоличествоСсылок", СтрТаблицаСсылок.Ссылка, 0)); Если НайденныеСтроки.Количество() > 0 Тогда НайденныеСтроки[0].КоличествоСсылок = СтрТаблицаСсылок.Количество; КонецЕсли; КонецЦикла; //Пусть максимальное количество каждого предопределенного элемента //будет наверху в группе каждого типа справочника ЗадублированныеСправочники.Сортировать("ИмяСправочника, ИмяПредопределенныхДанных, КоличествоСсылок Убыв"); //Покажем эту колонку пользователю ЭлементыФормы.ЗадублированныеСправочники.Колонки.КоличествоСсылок.Видимость = Истина; КонецПроцедуры Данная операция будет довольно длительной – производится поиск всех ссылающихся объектов, по окончании мы получим рекомендации:   Теперь пользователь может определить «правильный» элемент, руководствуясь данными о количестве ссылающихся объектов базы на конкретный элемент предопределенного справочника:   В теле процедуры обработчика нажатия кнопки «3. Оставить предопределенными только отмеченные» будем вызывать процедуру ОставитьТолькоОдинПредопределенный(). Кстати, спросим – помечать ли на удаление «неправильные».   Процедура ОставитьТолькоОдинПредопределенный() ПометкаУдаления = Ложь; ВыполненоУспешно = Ложь; //спросим – помечать ли на удаление «неправильные» Режим = РежимДиалогаВопрос.ДаНет; Ответ = Вопрос("Пометить на удаление дубли элементов?", Режим, 0); Если Ответ = КодВозвратаДиалога.Да Тогда ПометкаУдаления = Истина; КонецЕсли; ОставитьПредопределеннымКонтроль = ЗадублированныеСправочники.Выгрузить(); ОставитьПредопределеннымКонтроль.Свернуть("ИмяСправочника, ИмяПредопределенныхДанных", "ОставитьПредопределенным"); Для Каждого Стр Из ЗадублированныеСправочники Цикл ОтборНеУказанОставитьПредопределенным = Новый Структура("ИмяСправочника, ИмяПредопределенныхДанных, ОставитьПредопределенным", Стр.ИмяСправочника, Стр.ИмяПредопределенныхДанных, Ложь); Если НЕ Стр.ОставитьПредопределенным И ОставитьПредопределеннымКонтроль.НайтиСтроки(ОтборНеУказанОставитьПредопределенным).Количество() = 0 Тогда ЭлементОбъект = Стр.ЭлементСправочника.ПолучитьОбъект(); Если ЭлементОбъект <> Неопределено Тогда Если Не ЗначениеЗаполнено(ЭлементОбъект.Наименование) Тогда ЭлементОбъект.Наименование = ЭлементОбъект.ИмяПредопределенныхДанных; КонецЕсли; ЭлементОбъект.ИмяПредопределенныхДанных = "";//Именно в этом месте мы избавляемся от предопределенности ЭлементОбъект.ПометкаУдаления = ПометкаУдаления; ЭлементОбъект.Записать(); ВыполненоУспешно = Истина; Сообщить("Элемент" + ЭлементОбъект.Наименование + " справочника " + Стр.СинонимСправочника + " сделан непредопределенным."); КонецЕсли; КонецЕсли; КонецЦикла; //Проконтролируем результат, а также, возможно пользователь "работал" только с определенными справочниками Если ВыполненоУспешно Тогда ЗадублированныеСправочникиЗаполнить(); КонецЕсли; КонецПроцедуры Ну, и по традиции - во вложении исходная обработка. Ключевые фразы: 1С 8Файлы для скачивания:  search_dubl_own.zip

14:15:12 2.11.2016

Мой киборг-сеть программных разработок

Около 40 000 отчетов, обработок и компонент для 1С! Учитесь программированию у профессионалов. Это не теория, здесь только практика с живыми примерами, которые работают в других настоящих базах 1С: Предприятие....


http://www.mykib.org/rss.xml Получить информер из RSS-канала:  http://www.mykib.org/rss.xml http://www.mykib.org/rss.xml http://www.mykib.org просмотрен 6 раз

 

Добавить RSS к себе в ленту:


Добавить в список для экспорта в список для экспорта



<! >

Вернуться в раздел: Программы

страницы(73):


Реклама

Каталог RSS новостей:

Авто/мото/вело Администрации Безопасность Бизнес, финансы Благотворительность Блоги @Mail.Ru Блоги blogspot.com Блоги intwayblog.net Блоги wordpress.com Блоги ya.ru Блоги блог.ру Блоги, дневники Веб-разработка Города, регионы Деньги Дизайн Дневники LiveInternet Дневники@Diary.ru Дом, семья Женщинам Живой журнал Животные Законодательство Записи Twitter Знакомства Игры, игрушки Интернет Каталоги Кино, видео Компании Компьютеры Консультации Красота, здоровье Кредиты Кулинария Культура, искусство Литература Медицина Мобильная техника Мобильный контент Мода, стиль Мужчинам Музыка Недвижимость Новости Образование, наука Общество Объявления Оптимизация Отдых, туризм Подкасты Политика Порталы Пресс-релизы Природа, экология Программы Происшествия Промышленность Работа Радио, телевидение Развлечения Рамблер-Планета Реклама Религия Рукоделие СМИ, периодика Связь События Спорт Стена Facebook Страхование Строительство, ремонт Техника Технологии Товары, услуги Торговля Транспорт Файлы Форекс Форумы, сообщества Фото Электроника Юмор

<! >