<! >

Почему Пизанская башня пережила сильные землетрясения? Отвечает группа инженеров системы мониторинга инженерных конструкций Бристольского университета

Профессор Джордж Милонакис (George Mylonakis) из Департамента гражданского строительства Бристоля был приглашен присоединиться к исследовательской группе системы мониторинга инженерных конструкций из 16 человек под руководством профессора Камилло Нути (Camillo Nuti) Университета Roma Tre University, чтобы исследовать эту тайну Пизанской башни, которая в течение многих лет озадачивала инженеров. Несмотря на то, что она находится под углом в пять градусов к вертикали, что привело к смещению по высоте более чем на пять метров, 58-метровая башня сумела выжить, пережила неповрежденной, по крайней мере четыре сильных землетрясения, которые происходили в регионе с 1280 года. Учитывая уязвимость конструкции, которой едва удается стоять вертикально, ожидалось, что она будет иметь серьезный ущерб или даже разрушится из-за умеренной сейсмической активности. Удивительно, но этого не произошло, и с давних времен до сих пор это озадачивает инженеров. После изучения имеющейся сейсмологической, геотехнической и структурной информации исследовательская группа пришла к выводу, что выживание Пизанской Башни может быть связано с явлением, известным как динамическое взаимодействие почвенной структуры. Значительная высота и жесткость Башни в сочетании с мягкостью почвенного фундамента обусловливают существенное изменение вибрационных характеристик конструкции таким образом, что Башня не резонирует с колебаниями землетрясения. Возможно, это и есть ключ ее живучести. Профессор Милонакис, председатель по геотехническому и почвенно-структурному взаимодействию, и руководитель группы исследований землетрясений и геотехнических исследований на факультете гражданского строительства в Бристольском университете, сказал: "По иронии судьбы, та самая почва, которая вызвала неустойчивость и поставила Башню на грань краха, несет ответственность и за то, что помогла ей пережить эти сейсмические события". Результаты исследования были представлены на международных семинарах и будут официально объявлены на 16-й Европейской конференции по сейсмостойкой технике, которая состоится 18-21 июня 2018 года в Салониках, Греция. Ключевые фразы: интересные факты

10:57:31 5.06.2018

Пятница 11.05.2018 (Юмор)

Пятничная подборка (юмор) Натяжные потолки от фашистских захватчиков Эх, Серёга, что с тобой стало Ключевые фразы: юмор

10:26:54 11.05.2018

Обход блокировки Telegram в 1С:Предприятие 8

Данная публикация является дополнением дополнение к статьям: - "Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram" - "Получение отчета из 1C запросом в Telegram (отправка ботом файла Excel)" - "Интеграция 1С с мессенджером Telegram для любой конфигурации" 13 апреля Таганский суд Москвы удовлетворил иск Роскомнадзора о блокировке мессенджера Telegram на территории России. Поводом для блокировки стал отказ его создателя Павла Дурова передавать ФСБ ключи шифрования от переписки пользователей. Для обхода блокировки мы будем использовать прокси. Например, для TCP SOCKS5 контсрукция выглядит так: */ ИнтернетПрокси = Новый ИнтернетПрокси; ИнтернетПрокси.Установить("https", "socks5://адрес_прокси", порт, "логин", "пароль", Ложь); Таким образом, на момент написания данной публикации достаточно заменить строку Ответ = Соединение.Получить(Запрос); на следующую конструкцию: Попытка Ответ = Соединение.Получить(Запрос); Исключение ИнтернетПрокси = Новый ИнтернетПрокси; ИнтернетПрокси.Установить("https", "socks5://proxy.unlockgram.it", 5061, "Telegram", "7ab5fpm35yapnhjj", Ложь); Соединение = Новый HTTPСоединение(ПараметрыРаботыЗадания.Сервер,443,,, ИнтернетПрокси,,Новый ЗащищенноеСоединениеOpenSSL()); Запрос = Новый HTTPЗапрос(Ресурс); Попытка Ответ = Соединение.Получить(Запрос); Исключение возврат; КонецПопытки; КонецПопытки; Ключевые фразы: 1С 8Telegram

10:56:44 19.04.2018

Пятница 13.04.2018 (Юмор)

Пятница 13-е. Пятничная подборка (юмор) Ключевые фразы: юмор

14:17:24 11.04.2018

Интеграция 1С с мессенджером Telegram для любой конфигурации

Интеграция 1С с мессенджером Telegram для любой конфигурации (типовой или самописной) для любого режима запуска (тонкий, толстый клиент). Для встраивания системы достаточно объединить свою конфигурацию с предложенной — в результате в Вашей конфигурации появится подсистема Телеграм. Весь функционал (код) является открытым для доработки/изменения. Платформа 1С 8.3.6 и выше. Взаимодействие происходит при помощи регламентного задания. Состав: Справочник «Телеграм боты» - список ботов телеграмм, с возможностью проверки правильности: «Отправить сообщение пользователю Telegram» - список ботов Telegram и их пользователей, с возможностью интерактивной отправки текстового сообщения или файла одному или нескольким пользователям. «Телеграм настройка работы ботов» - настройка расписания и исключительных ситуаций работы регламентного задания: «Соответствие пользователей Телеграм» (эта опция не обязательная) - регистр сведений, в котором будут указаны соответствия пользователей Телеграм с элементами справочника в Вашей конфигурации (например, справочником «Пользователи» в типовых конфигурациях). В коде есть закомментированный пример авторизации пользователей - закомментирован по той причине, что пользователя бота может не быть в базе 1С. Если Вам необходима обязательная авторизация — посмотрите этот пример. Бот принимает следующие команды пользователей Telegram: /start – начало работы /help - помощь /login - авторизация /report – пример получения отчета в формате Excel (xlsx) Добавление команд и ответов на них Вы можете добавить в модуле «ТелеграмНаСервере» в процедуре «ПрочитатьДвоичныеДанныеОтветаБоту» Ссылка, для скачивания. Ключевые фразы: 1С 8Telegram

11:20:54 5.03.2018

Особенности 1С Предприятие 8, которые мало кто знает. Группировка в отчете (как в Excel)

Часто бывает так, что в отчетах большое количество группировок («плюсики») Для управления группировками можно кликнуть мышкой на пустое пространство, в котором расположено управление группировками («плюсики») и установить требуемый уровень группировок. Но для более легкого управления можно включить отображение колонок (меню «Таблица» – «Вид» – «Отображать заголовки») в таблице и выбор уровня группировок будет аналогичен выбору уровня группировок в Excel Ключевые фразы: Будни1СОсобенности 1С Предприятие 8

11:34:02 7.12.2017

Особенности 1С Предприятие 8, которые мало кто знает. Настройка списков пользователем – добавление колонок, которые не предусмотрел разработчик.

Часто в списках документов, справочников и др. не хватает колонок для просмотра и отбора информации. В настройках формы можно управлять только теми колонками, которые предпочли сделать доступными разработчики (меню «Все действия» - «Изменить форму»). Достаточно выбрать ссылочное поле на элемент справочника или документ (в примере на рисунке - это поле «Автор» – ссылка на справочник «Пользователи») и нажать кнопку «Добавить поля» (эта кнопка станет доступной) и мы можем добавить в список реквизиты этого объекта: И не всегда консультанты из компаний франчайзи 1С вам расскажут об этом. Кстати, для списков, которые содержат различные виды документов это тоже работает. Ключевые фразы: Будни1СОсобенности 1С Предприятие 8

11:13:33 5.12.2017

Особенности 1С Предприятие 8, которые мало кто знает. Быстрый ввод даты.

Если мы вводим дату текущего года, то год в поле вводить не обязательно – достаточно ввести только день и месяц. После нажатия Enter текущий год установится автоматически. Аналогично и с текущим месяцем – достаточно только ввести день и нажать Enter, а месяц и год установятся автоматом. Ключевые фразы: Будни1С 8Особенности 1С Предприятие 8

10:53:06 5.12.2017

Пятница 10.11.2017 (Юмор)

Нецензурные этикетки Пятничная подборка (юмор) Ключевые фразы: юмор

10:34:04 10.11.2017

1С: Предприятие 8. Условное оформление – сравнение с текущей датой при каждом обновлении динамического списка

В данной публикации рассмотрим пример раскрашивания строк просроченных документов в журнале документов (динамическом списке) от текущей даты и текущего времени. Наша задача – раскрасить розовым цветом строку, если Контрольный срок меньше Текущей даты с учетом того, что текущая дата постоянно меняется. То есть текущую дату надо считывать динамически, а не определять при первом открытии. Мы узнаем, как в управляемой форме: - использовать обработчик ожидания; - программно настроить условное оформление динамического списка Допустим, у нас есть документ «Умный заказ» с реквизитом «КонтрольныйСрок» и типом «Дата» (состав даты «Дата и время»):   И журнал документов «УмныйЗаказ» с графой «КонтрольныйСрок», соответствующей этому реквизиту:   Наша задача – раскрасить розовым цветом строку, если Контрольный срок меньше Текущей даты с учетом того, что текущая дата постоянно изменяется. Создадим управляемую форму:   Теперь при создании на сервере мы вызовем процедуру раскрашивания строк «ОбновленияОтображенияПросрочкиНаСервере».  И будем вызывать эту процедуру с заданной периодичностью. То есть, при создании на сервере: */ &НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) ОбновленияОтображенияПросрочкиНаСервере(); КонецПроцедуры При открытии подключим обработчик ожидания: */ &НаКлиенте Процедура ПриОткрытии(Отказ) ПериодАвтообновления = 30;//Здесь указываем период автообновления динамического списка ЭтотОбъект.Элементы.Список.ПериодАвтоОбновления = ПериодАвтообновления; ПодключитьОбработчикОжидания("ОбновленияОтображенияПросрочки", ПериодАвтообновления,Ложь); КонецПроцедуры &НаКлиенте Процедура ОбновленияОтображенияПросрочки() Экспорт ОбновленияОтображенияПросрочкиНаСервере(); КонецПроцедуры Таким образом, с периодичностью, указанной в переменной ПериодАвтообновления мы будем вызывать процедуру раскрашивания строк: */ &НаСервере Процедура ОбновленияОтображенияПросрочкиНаСервере() //Красим если просрочен срок УО = ЭтотОбъект.Список.КомпоновщикНастроек.ФиксированныеНастройки.УсловноеОформление.Элементы; //если условное оформление уже задано, то удалим его и создадим заново Для каждого Стр Из УО Цикл Если Стр.Представление="Отбор_просрочки" Тогда УО.Удалить(Стр); Прервать; КонецЕсли; КонецЦикла; //создание условного оформления ЭлементУО = УО.Добавить(); ЭлементУО.Представление="Отбор_просрочки"; ЭлементУО.Использование = Истина; ЭлементУО.Оформление.УстановитьЗначениеПараметра("ЦветФона", WebЦвета.Розовый); ЭлементУсловия = ЭлементУО.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных")); ЭлементУсловия.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("КонтрольныйСрок"); ЭлементУсловия.ВидСравнения = ВидСравненияКомпоновкиДанных.Меньше; ЭлементУсловия.ПравоеЗначение = ТекущаяДата(); КонецПроцедуры В этой процедуре мы программно создали условное оформление нашего динамического списка. Результат:     Ключевые фразы: 1С 8

10:25:41 14.03.2017

Мой киборг-сеть программных разработок

Около 40 000 отчетов, обработок и компонент для 1С! Учитесь программированию у профессионалов. Это не теория, здесь только практика с живыми примерами, которые работают в других настоящих базах 1С: Предприятие....


http://www.mykib.org/rss.xml Получить информер из RSS-канала:  http://www.mykib.org/rss.xml http://www.mykib.org/rss.xml https://www.mykib.org просмотрен 83 раза

 

Добавить RSS к себе в ленту:


Добавить в список для экспорта в список для экспорта



<! >

Вернуться в раздел: Программы

страницы(73):


Реклама

Каталог RSS новостей:

Авто/мото/вело Администрации Безопасность Бизнес, финансы Благотворительность Блоги @Mail.Ru Блоги blogspot.com Блоги intwayblog.net Блоги wordpress.com Блоги ya.ru Блоги блог.ру Блоги, дневники Веб-разработка Города, регионы Деньги Дизайн Дневники LiveInternet Дневники@Diary.ru Дом, семья Женщинам Живой журнал Животные Законодательство Записи Twitter Знакомства Игры, игрушки Интернет Каталоги Кино, видео Компании Компьютеры Консультации Красота, здоровье Кредиты Кулинария Культура, искусство Литература Медицина Мобильная техника Мобильный контент Мода, стиль Мужчинам Музыка Недвижимость Новости Образование, наука Общество Объявления Оптимизация Отдых, туризм Подкасты Политика Порталы Пресс-релизы Природа, экология Программы Происшествия Промышленность Работа Радио, телевидение Развлечения Рамблер-Планета Реклама Религия Рукоделие СМИ, периодика Связь События Спорт Стена Facebook Страхование Строительство, ремонт Техника Технологии Товары, услуги Торговля Транспорт Файлы Форекс Форумы, сообщества Фото Электроника Юмор

<! >